» View Question
Mercury2003

Mercur ... 2/23/2020

2003 Mercury Grand Marquis LS 8 Cyl 4.60L

Body & Interior

Why wont my heater/AC fan blow any air?

I purchased this car one month ago and the heater fan stopped blowing air literally as I drove it off the car lot, on the way home several dash lights came on and the headlights were dim. It stalled twice and it needed to be jump started both times just to get it in the driveway. I changed the alternator out and everything worked fine after that, even the heater fan. Now last week the heater fan stopped running again, (alternator seems fine) the car is new to me and I ran the blower on high 90% of the time having a short drive to work and back so Im not positive if the other fan settings were working properly or not. All it does is makes a clicking sound as I push the fan setting wheel up to its highest setting and release it. I changed out the blower motor but that doesn't seem to be the problem either. I was going to change the resistor next but Im not sure if that is the problem either. Ive seen several things online about a "blend door" and Im not sure where to go from h

1 Answer


Jimm

Jimm 2/26/2020

First question - is there any used car warranty? Typically, there is at least a 30 - 90 day warranty period - so check that first. Next, have the alternator and charging system tested for free - at any local auto parts store.

Before replacing any more parts and just guessing at the issue - use a shop manual and volt-ohm meter to test and diagnose for the electrical issues in the heater / blower motor circuit. Check the fuses and relays associated with the blower motor and heater fan operation.

Check the fan switch as the next step - use the electrical schematic and volt-ohm meter. Next, check the resistor using the volt-ohm meter to test the resistance - with the wiring unplugged from the resistor.

It seems highly likely that it's the Blower Motor Speed Controller. It's a known problem on the last couple generations of this platform and a redesigned part has been issued (8W7Z-19E624-A). It's possible that it's just a bad blower motor, or both the blower motor and controller could be bad.
The blower motor and the controller are in the engine bay on the passenger side of the firewall. The blower motor connector should have power on the brown-orange wire. The orange-red wire is the ground. If they're both good, it's a bad blower motor. If there is no ground, it's time to check the controller.

Reply
0

Answer this question

( characters left)

Follow Question

what's this?
advertisement
advertisement