Auto Answers » Engine » Buick » Page 6

Buick engine repair questions and answers

Post your Buick engine question or share what you know by answering questions

1969 Questions
Sort by:
  • Mike
    Mike - 1994 Buick Park Avenue - Engine - 9/8/2014
    Cruise control will not stay at selected speed.
    The cruise control works fine when there is no strain on it. But when going up a hill it will not keep up to speed selected, it doesn't drop completely out just starts going slower. After car starts going slower If you put the accelerator down to help, then let off ...
     
    0 answer
  • knowdealneil
    knowdealneil - 2000 Buick Regal - Engine - 9/4/2014
    What is possible problem
    service engine light soon has been on for a week, add coolant light is flashing. have service radiator; water pump works, thermostat works, engine does not over heat. system has problem from start up, oil change 7/1/14 and is clean. what could problem be?
     
    • lesabre man
      9/4/2014 lesabre man
      Have someone hook a scan tool to your vehicle and see exactly what codes you are getting, but you could also test the coolant temp sensor. Sounds fairly simple, with a little more information.
  • lesabre man
    lesabre man - 1995 Buick LeSabre - Engine - 9/2/2014
    Lesabre just stalls sporadically, then starts right back up.
    Have replaced crank sensor, harmonic balancer, MAF sensor, 02 sensor, fuel regulator, and tested IAC and MAP sensors. Fuel pressures are all good. New fuel filter, air cleaner and spark plugs as well. Removed entire throttle body and completely cleaned it too. Car ...
     
    0 answer
  • Fudge
    Fudge - 2000 Buick Century - Engine - 9/1/2014
    Why is my car revving in park?
    Sometimes when my Buick century is in park it will begin to rev, or when I'm driving, around 30mph, I have to ride my brakes the whole time to stay at the speed limit.
     
    0 answer
  • stan
    stan - 1991 Buick Skylark - Engine - 8/31/2014
    Code 15 open circut, mechanic says i have an open circut
    cooling fan runs constantly,replaced temp sensor, mechanic says open circut
     
    0 answer
  • adavis219
    adavis219 - 1998 Buick Century - Engine - 8/30/2014
    Does a large gray cloud from my exhaust mean head gaskets?
    I just let a friend try to replace my LIM gaskets but he didn't do it properly so the didn't seal. Having misplaced faith in him, i did not realize it right away. On the cars first start after the LIM job it started up, sounded good, but then died cause it was out ...
     
    0 answer
  • Shyenne
    Shyenne - 1987 Buick Century - Engine - 8/28/2014
    Why is my car revving up and down and dying when I turn the headlights on and push the brakes?
    The mileage is 91,615. We thought it was the brake switch so we got a new one and it is still acting the way it was before. When we take the brake switch out though, the car runs better. It does it during the day and night. Sometimes the car will die while we are ...
     
    • jdl
      8/28/2014 jdl
      I'd have to make sure the battery and charging system are working ok. Check battery wiring,cables, also. I believe some of the national brand auto stores will check those systems for free.

      Check for applicable trouble codes, your obd1 so you should be able to check codes, yourself. To check codes, use a jumper wire between the A & B terminals at the data link connector, lower edge of dash. Turn key just till the dash light come on, no further. The mil on the dash starts flashing, you count the flashes to get the codes. Your looking for two digit codes.

      Check your map sensor. How long since a tune-up?
  • rbsutherland
    rbsutherland - 2005 Buick LeSabre - Engine - 8/24/2014
    Engine will not start
    2 crankshaft position sensors have been replaced 1st one lasted 2 months the second replaced 1 month later. The coils were also replaced at the that time. Now 1 month later the engine will not start. 74000 miles. Engines always died while running. AAA roadside ...
     
    • jdl
      8/24/2014 jdl
      Did you find a crank sensor trouble code? What was the code number? Are you using quality parts? Did you check wiring connector and wiring circuits? Also check the trigger for the crank sensor. Check the camshaft position sensor and circuitry,

      At the crank sensor connector, you can check ref voltage--ground and signal.
  • Buick 2003
    Buick 2003 - 2003 Buick LeSabre - Engine - 8/20/2014
    Changed water pump, belt, radiator and thermostat and car keeps overheating, seems something is blocking engine radiato
    Radiator keeps backflowing even though its brand new, what could cause water not to flow from engine through radiator if parts are new? Could an engine flush work? Car has 120,000 miles
     
    0 answer
  • 10money
    10money - 1993 Buick LeSabre - Engine - 8/16/2014
    Why is my car doing this??
    Ok i have a 1993 Buick Lesabre & when i crank it....it sounds horrible. you can smell gas & there is a very loud squeal by the EGR valve on the driver side. When i drive it the brakes get hard and it feels like a go kart chugging when its driving....Please Help
     
    0 answer
  • AutoMD Member
    AutoMD Member - 2007 Buick LaCrosse - Engine - 8/11/2014
    You start the car and start driving it just stops if you get out and move the wires with a plug on it that go,s in coil
    pack then it starts and you can drive it
     
    0 answer
  • Draven
    Draven - 1981 Buick Electra - Engine - 8/5/2014
    What are the following vacuum ports on or around my engine?
    My car has an Electronic Rochester Quadrajet carburetor on it. 1.) A little, shiny black thing that says "control" on top (http://i913.photobucket.com/albums/ac334/sonicfast01/IMG_0069_zps810f722f.jpg). One vacuum tube leads to the bottom of my carburetor, another ...
     
  • bobby tart
    bobby tart - 2000 Buick Regal - Engine - 8/1/2014
    Can not get it to crank or start
    have installed new lock and resister key still nothing has appro 140 thousand miles.
     
    • AutoMD Member
      8/1/2014 AutoMD Member
      this sounds like the issue I had. I found this site it has a module that you can even install yourself
      hope it helps
      The security, antitheft or lock picture/icon is a visual indication that something in the car's antitheft system is failing. In most GM cars and trucks there is a hidden system that most people are unaware even exists. From the moment you put your key in the ignition, there begins a constant line of communication between your key's security chip or transponder, to the ignition's lock cylinder, and then to the car's TDM (Theft Deterrent Module). These 3 parts are in CONSTANT communication. If the key is in the ignition, then these parts are sending signals to each other. The security light illuminates when that signal gets broken, even just for a second. When the signal breaks, the car misinterprets this as an attempt at theft and goes into antitheft mode. The car thinks its being stolen or hotwired because it is not getting that signal from YOUR specific key. This is why the security light turns on and shuts down your vehicle. This link explains it pretty well.

      http://vatspasslockpasskeysecurityhelp.yolasite.com/
  • AutoMD Member
    AutoMD Member - 2004 Buick Rendezvous - Engine - 7/30/2014
    Can AC be disconnected??
    I just bought my car from a private party. I was told the ac had been "disconnected" by the tow company she bought it from. When the car is running there is no power in the climate control and no fans blowing. Not even the ac light comes on. This is the same for the ...
     
    0 answer
  • bobby tart
    bobby tart - 2000 Buick Regal - Engine - 7/30/2014
    Will not crank or start
    have replaced the lock@key whith new resister c ohm the same as the old key it still will not crank or start
     
    0 answer