» View Question
Cooter178

Cooter178 5/31/2011

1999 Mercury Cougar V6 6 Cyl 2.5L

Body & Interior

Battery not charging

friend hooked up jumper cable backwards, replaced battery, alt. still won't charge.

4 Answers


Spoon Sports

Spoon Sports 5/31/2011

Anything else you are not telling me? Because right now all i can think of is a new battery, there are other cases wherein every fuse existent to your car and man-kind blew up. Worst case scenario would be a burned ECU

Reply
0
Spoon Sports

Cooter178 5/31/2011

So far I have found that the reverse polarity protection diodes(one in fuse panel under the hood and one under ths dash) are fried. Where can I find replacements?

Bill

Bill 5/31/2011

Look for a fusible link on positive battery cable and or/and with this terminal disconnected run a continuity *OHM*
test between terminal clamp and alternator bat post terminal

Reply
0
Bill

HouseCallAuto 5/31/2011

That would close in on it also. This test will uncover an open circuit.

HouseCallAuto

HouseCallAuto 5/31/2011

Replace the 175 amp mega fuse located at the rear of the engine, center of rear valve cover under the coil bracket.

Reply
0
HouseCallAuto

Cooter178 6/1/2011

Replaced fuse now showing 14 plus volts at battery but the securty system still going off and radio not working. any ideas this thing is driving me crazy.

Spoon Sports

Spoon Sports 6/10/2011

Up for HCA, im stumped on this one

Reply
0

Answer this question

( characters left)

Follow Question

what's this?
advertisement
advertisement