Auto Answers » View Question
Richard_Bragdon
Richar ... 3/29/2010
2004 Chevrolet Suburban 1500 LT 8Cyl5.3L - Transmissions & Drivetrains
my speedometer isn't working properly, was told it could be speed sensor. is this a correct speculation?
4 Answers
  • Chris2000
    Chris2000 3/29/2010
    It could be without actually testing it can't be sure. it could also be a problem at the cluster. Good thing is the speed sensor is pretty reasonable you can try a new one and see if it fixes it. Found them on this site cut and paste the link. http://cpwstore.carpartswholesale.com/catalog/ 1500,submodel:LT,engine:8 Cyl 5.3L,universal:0)
    Reply
    0
  • Chris2000
    Chris2000 3/29/2010
    It could be without actually testing it can't be sure. it could also be a problem at the cluster. Good thing is the speed sensor is pretty reasonable you can try a new one and see if it fixes it. Found them on this site cut and paste the link. http://cpwstore.carpartswholesale.com/catalog/ 1500,submodel:LT,engine:8 Cyl 5.3L,universal:0)
    Reply
    0
  • monlaster
    monlaster 7/2/2010
    I have an '03 my speedometer also went out. I changed my speed sensor and it did not make a difference. I would say it is in the cluster. About 2 years ago I received a letter saying the there were defects in the cluster.
    Reply
    0
  • JunkFixer
    JunkFixer 7/2/2010
    These trucks are notorious for instrument cluster failure, so much so that they are already available pre-programmed aftermarket.
    Reply
    0
close

Preview Answer

 
AutoMD Verified Customer
AutoMD obtained proof this customer interacted with the shop.