Auto Answers » Preventive Maintenance » Oldsmobile

Oldsmobile preventive maintenance repair questions and answers

Post your Oldsmobile preventive maintenance question or share what you know by answering questions

Browse Oldsmobile Categories

211 Questions
Sort by:
  •  beckeebrownie
    beckeebrownie - 2003 Oldsmobile Alero - Preventive Maintenance - 11/14/2014
    Totally messed up my car by trying to install after market head unit... Help please
    So when I put it in at first and connected everything the unit worked fine. But I was having trouble getting it to fit bc it was a double din. First my car died from having the key in ignition bc I needed to have my car on first gear to open all the things to get to ...
     
    0 answer
  •  beckeebrownie
    beckeebrownie - 2003 Oldsmobile Alero - Preventive Maintenance - 11/14/2014
    Totally messed up my car by trying to install after market head unit... Help please
    So when I put it in at first and connected everything the unit worked fine. But I was having trouble getting it to fit bc it was a double din. First my car died from having the key in ignition bc I needed to have my car on first gear to open all the things to get to ...
     
    0 answer
  • coco
    coco - 1992 Oldsmobile 88 - Preventive Maintenance - 11/2/2014
    WHAT KEEP CAUSING MY IGNITION CONTROL MODULE TO GO BAD
    HI I HAVE A 1992 Oldsmobile delta 88 my car will turn off when my gas is getting low and when getting off the freeway are when stoping at a light my check engine light is on I just replaced my ignition control module onOctober 18 and its already bad and its jus nov 1
     
    • alex
      11/2/2014 alex
      the dielectric greas goes under the module not on the plug also clean under it the grease is to dissapate heat also bad plugs and wires also cause premature failure.
  • coco
    coco - 1992 Oldsmobile 88 - Preventive Maintenance - 11/1/2014
    What keep causing my ignition control module to go bad
    When I stop at a light are get off the free way sometimes it will turn off but when I put it in park and try starting it then it starts rite up and when my gas get low it turns of but when I put it in park it will start rite upi just changed my ignition control ...
     
    0 answer
  • coco
    coco - 1992 Oldsmobile 88 - Preventive Maintenance - 11/1/2014
    What keep causing my ignition control module to go bad
    When I stop at a light are get off the free way sometimes it will turn off but when I put it in park and try starting it then it starts rite up and when my gas get low it turns of but when I put it in park it will start rite upi just changed my ignition control ...
     
    0 answer
  • davew513
    davew513 - 1999 Oldsmobile Silhouette - Preventive Maintenance - 10/21/2014
    After changing my alternator battery and my starter my van cranks but won't turn over what could this be ?
    Prior to it breaking down it would stall out but I would just throw it in neutral and start it back up then it went out completely so I changed the starter and charged the battery and it cranked up and got me home but then it never started again after that I did my ...
     
    0 answer
  • Nichole
    Nichole - 2001 Oldsmobile Aurora - Preventive Maintenance - 9/2/2014
    Why is my air conditioning blowing only out the defrosting vents.
    My car was recently worked on and the battery was disconnected. The mechanic said it needed to be recalibrated for it to blow out all the vents. He can't seem to figure out the problem or calibrate it. What could the problem be from.
     
    0 answer
  • AutoMD Member
    AutoMD Member - 1999 Oldsmobile Aurora - Preventive Maintenance - 5/24/2014
    Headlights & taillights
    Hi, I have a 1999 Oldsmobile Aurora with 72,000 miles. I noticed today that the headlights and taillights were flickering off and on and the car was off. The lights continue to flicker while it's running and driving. There's also a loud buzzing sound in the ...
     
    • GT500Knights
      5/24/2014 GT500Knights
      Seems to be a loose connection or a bad relay(s). Check fuses and relays. Also, check the switch for the headlights. It's possible that there is an intermittent short inside the switch itself.
  • SlowBurn369
    SlowBurn369 - 2000 Oldsmobile Intrigue - Preventive Maintenance - 4/24/2014
    My 2000 Oldsmobile Intrigue makes this horrible low rumbling noise when completely stopped while in Drive...
    The car does not make this sound as soon as i let off the break or while it's in other gears, such as Park, Reverse, or Neutral...(not sure about 1st or 2nd gear) I know that the cars exhaust is in need of a couple repairs, but this noise only seems to happen when ...
     
    0 answer
  • SlowBurn369
    SlowBurn369 - 2000 Oldsmobile Intrigue - Preventive Maintenance - 4/24/2014
    My 2000 Oldsmobile Intrigue makes this horrible low rumbling noise when completely stopped while in Drive...
    The car does not make this sound as soon as i let off the break or while it's in other gears, such as Park, Reverse, or Neutral...(not sure about 1st or 2nd gear) I know that the cars exhaust is in need of a couple repairs, but this noise only seems to happen when ...
     
    0 answer
  • peeberhopper
    peeberhopper - 1991 Oldsmobile 98 - Preventive Maintenance - 9/22/2013
    Where is inline fuse
    I have no powr
     
    • Jimm
      9/22/2013 Jimm
      There is an inline fuse just next to the ECM (engine control module). Also, check the large ampere rated fuses in the power distribution box under the hhod.
  • cjwatkins
    cjwatkins - 2002 Oldsmobile Alero - Preventive Maintenance - 9/19/2013
    Summer or winter, after 3 hrs on the road the blower quits blowing air through floor,dash, defrost vents.
    Blower sound changes when you turn speed knob but still no air. happens almost all the time after 3 hrs on a road trip
     
    • CVO
      9/19/2013 CVO
      Apply a direct 12 volts to the blower connector, if the blower motor doesn't run, then replace it as necessary.
      CVO
      9/19/2013 cjwatkins
      but if the blower works during the first 3 hrs of road road trip how will this help diag. the problem
      CVO
      9/19/2013 CVO
      Does the motor run in all speeds low, m1, m2, m3 and high during the first 3 hours ? Yes, check the motor control logic.
      Use this 2002\GC\WRGC02ALERO009a as a reference to access in the free wiring diagrams @ www.bbbind.com
    • HouseCallAuto
      9/19/2013 HouseCallAuto
      Remove the blower motor ass'y. I can't be sure about alero but many or most GM vehicles have to blow the air through the evaporator core first before the air even reaches the heater core. I know that the early 90's full size buick and olds used to get blocked evaporators and you had to clean out the fins or the air would not blow out the vents with force although you would hear it.
      HouseCallAuto
      9/20/2013 cjwatkins
      yesall speedsworkduring first 3 hrs and seem to have good airmovement until it quits
  • scasti1
    scasti1 - 1989 Oldsmobile Delta 88 - Preventive Maintenance - 9/3/2013
    Did I install the Fuel Filter wrong or ruin the fuel pump? I ran it out of gas by accident. Then put in a gallon.
    It took a long time to start up (pump gas through). I then replaced the fuel filter. It did not leak. Then filled up car and it ran great for 50 miles. Now its running a bit rough. Getting 50 miles seems to indicate the filter was installed OK? Did I ruin the pump?
     
    • HouseCallAuto
      9/3/2013 HouseCallAuto
      Don't draw premature conclusions about what you think happened here. Maybe you didn't run out of gas at all and maybe what you have is something unrelated to the fuel pump or fuel filter. Start by checking fuel pressure with a fuel pressure gauge so you can dismiss the fuel system. Pressure should be 40 to 47 psi with key on engine off, and 31 to 43 with engine idling.
      HouseCallAuto
      9/3/2013 scasti1
      I appreciate the answer very much. I did run out of gas with the subsequent very difficult start once I put a gallon in. The fuel pressure gauge is a great idea. I will do this first.
  • scasti1
    scasti1 - 1989 Oldsmobile Delta 88 - Preventive Maintenance - 9/3/2013
    Did I put in a bad fuel filter or ruin the fuel pump?
    Accidentally ran car out gas to get it low to replace a filter. Added a gallon and it took a long time to start. Ran fine. Replaced the filter myself. Did not leak. Filled up tank. Ran great for 60 miles then started to run kind of sluggish.
     
    0 answer
  • tueseyes
    tueseyes - 1999 Oldsmobile Intrigue - Preventive Maintenance - 7/7/2013
    WHY DOES MY CAR HAVE THIS SCREEING SOUND ON THE PASSENGER SIDE OF THE CAR?
    WHEN CAR IS STARTED IT HAS THIS SCREEING SOUND AS IF IT,S SOMETHING TURING AND NEEDS TO BE OILED.THE SOUND DOES,NT GO AWAY WHILE DRIVING.
     
    • Jimm
      7/7/2013 Jimm
      Need more information - does the sound change - such as when the brakes are applied? Does the noise change with driving conditions? Does the noise change with the vehicle speed? Have you raised the hood to listen for the noise and determine if maybe the drive belt or any belt-driven accessory may be the cause?

      If the screeching sound goes away when the brakes are applied - then the noise you are hearing is the brake pad wear indicators; small bits of metal embedded inside the front brake pads to indicate time to change the brake pads. The metal scrapes on the brake rotor surface to make the sound.

      Check the many on-line auto parts sources, such as; www.partstrain.com, www.partsgeek.com, www.carpartswarehouse.com, or www.rockauto.com for the replacement parts.