Auto Answers » Engine » Mercedes-Benz » Page 11

Mercedes-Benz engine repair questions and answers

Post your Mercedes-Benz engine question or share what you know by answering questions

1685 Questions
Sort by:
  • MikeJ
    MikeJ - 1987 Mercedes Benz 300D - Engine - 2/25/2013
    What would cause the car to run rough until warmed to normal driving temperature?
    On cold start, car runs rough, lots of smoke out the exhaust, but smooths out and runs great after engine warmup. Have replaced both fuel filters, glow plugs, all fuel injectors and the washers on the injector pump nozzles. Have checked for air leaks on the ...
     
    • tomclark88
      2/25/2013 tomclark88
      did you check the glow plug relay? when you turn on the key, does the yellow glow plug light come on for a few seconds and go off or does the light come on after the engine starts? if its coming on after the engine starts it could be a bad glow plug (yes, you can get a bad one so you should check them again) or the relay may be malfunctioning not allowing the glow plugs to get hot enough.
  • car
    car - 1985 Mercedes Benz 300D - Engine - 2/25/2013
    Engine not shutting off with key
    Door locks and trans shifting hard also
     
    • colin
      4/10/2012 colin
      if a diesel then its the stop valve solonoid on the injector pump for a vehicle of this age,as for the door locks and the gear change then check the vacumn pipes from the inlet manifold as they are no doubt porous also the vacumn reserve tank as well in case it corroded through,the gearchange and the door locks all work off the vacumn of the engine ,sorry if it is a diesel then it will have a vacumn pump driven from the engine either on the end of the head driven by the cam or on the back of the alternator .look at the back of the injector pimp as some old vehicles it was taken from here
    • tomclark88
      2/25/2013 tomclark88
      you have a vacuum leak somewhere. check all the vacuum lines.
  • alboho
    alboho - 1983 Mercedes Benz 300D - Engine - 2/25/2013
    Runs good for a while then looses a ton of power. What should I be checking?
    My turbo diesel 300D is loosing power when warm. It happens all the time. runs good when cold. Warms up and looses power. Someone told me that some relay is overheating. I don't know if that's the issue. I just need some advice. thanks
     
    • 300TD
      10/11/2012 300TD
      You need to Clean intake manifold.
    • 300TD
      10/11/2012 300TD
      ... and EGR valve to.
    • tomclark88
      2/25/2013 tomclark88
      check the turbo. there is a valve on the turbo that opens by vacuum when you hit the gas to allow compressed air into the intake. if you have a vacuum leak or broken vacuum line, the valve will not open and the symptom is exactly as you described. locate the valve and follow the vacuum lines to see if you can locate a leak or disconnection. i had the same problem recently and somehow, the vacuum lines had become disconnected. i probably knocked it loose while checking the transmisison fluid and leaning into the engine compartment.
  • rdputts54
    rdputts54 - 1991 Mercedes Benz 300SE - Engine - 2/24/2013
    The blower for the heat and ac has stoped working what the problem be
    it stop when driveing it has not can back on at all
     
    0 answer
  • mk.mottsr
     
    • Jimm
      2/22/2013 Jimm
      The 380SL means '3.8L' originally with a 3.8L V8 engine. If the car has a straight six cylinder, then it was replaced somewhere along the way.
      Jimm
      2/25/2013 mk.mottsr
      Thank you very much Jimm. The car is not mine. It belongs to a friend and it was her mothers car. Its been sitting for over four years. No rust and it says 56.000 on the dash. Its looks all original. She fell on hard times now she needs to sell it. I have to try and get it started today. First im going to put a new a battery in there.
  • nabzm26
    nabzm26 - 2004 Mercedes Benz C230 - Engine - 2/21/2013
    My battery alternator light comes on and then srs, esp and abs lights also right up, what is the reason?
    It only occurs on really cold days, i have read that it could be the voltage regulator, just wanted to make sure before i take it to a mechanic. The heat and the radio also stop working
     
    • HouseCallAuto
      2/21/2013 HouseCallAuto
      I suspect that you have a bad alternator. when the modules that control the other things like abs and srs receive low voltage they report it by turning on warning lights.
  • nabzm26
    nabzm26 - 2004 Mercedes Benz C230 - Engine - 2/21/2013
    My battery alternator light comes on and then srs, esp and abs lights also right up, what is the reason?
    It only occurs on really cold days, i have read that it could be the voltage regulator, just wanted to make sure before i take it to a mechanic. The heat and the radio also stop working
     
    • Bill
      2/21/2013 Bill
      Most alternators these days incorporate the voltage regulator, so I would venture a guess unless you have a way (Meter) to check whether the alternator is outputting voltage at the correct 13.5-14.5 voltsDC it would seem your alternator is the problem considering information you've given.
  • clarence1734
    clarence1734 - 1993 Mercedes Benz 190E - Engine - 2/19/2013
    Hard starting in the morning
    my 1993 mercades 190e with 162,000 miles is hard as hell to start in the morning it turns over fine but when it starts it just chug chugs untel it kicks in runs normal and then starts fine the rest of the day. i have had the fuel filter and the accumulater changed. ...
     
    • HouseCallAuto
      2/19/2013 HouseCallAuto
      Replace the fuse for the overprotection relay. When this fuse is open, no power will get to the cold start injector. 10amp fuse behind battery.
      HouseCallAuto
      2/22/2014 AutoMD Member
      would this also apply for a 1988 300e, i hace the same problem.
  • jbjdpo
    jbjdpo - 2006 Mercedes Benz C230 - Engine - 2/18/2013
    What is the breather cover?
    the technician said that the breather cover is starting to seep.
     
    0 answer
  • scuffee13
    scuffee13 - 1996 Mercedes Benz S500 - Engine - 2/15/2013
    How to replace serpentine belt
    need to replace serpentine belt
     
    • Jimm
      2/15/2013 Jimm
      Check the 'How-To-Guides' feature on the AutoMD website. You'll need to loosen (release tension) on the drive belt tensioner to install the new drive belt.
      Try the many on-line auto parts sources, such as; www.autopartswarehouse.com, www.partsgeek.com and www.rockauto.com for the replacement parts.
  • rannight
    rannight - 2001 Mercedes Benz ML320 - Engine - 2/13/2013
    No sound on fm radio, but plays on c/d's and am. also door lock want work
     
    0 answer
  • hunter2546
    hunter2546 - 1988 Mercedes Benz 300E - Engine - 2/13/2013
    Fuel smell when shut off
    when driven a short distence and shut off have strong fuel smell no fuel leaks found
     
    0 answer
  • zarembamarek1
    zarembamarek1 - 1987 Mercedes Benz 190D - Engine - 2/11/2013
    What vacuum my car need to operat correct?
    The breaks work poor.In summer time if I driving up hill heat turns on automaticly.
     
    0 answer
  • echavy48_
    echavy48_ - 1991 Mercedes Benz 190E - Engine - 2/9/2013
    Do I need to order a radiator that has an oil cooler for 1991 190e 2.3 Mercedes.
    I am going to order a radiator online. All radiators listed indicate having transmission fluid cooler but do not have oil cooler. Is that something I need to be concerned about?
     
    • Jimm
      2/9/2013 Jimm
      If the vehicle has the automatic transmission, then the radiator with the fluid cooler would be correct. Try the many on-line auto parts sources, such as; www.autopartswarehouse.com, www.partsgeek.com and www.rockauto.com for the replacement parts. For example, they (RockAuto) lists the replacement radiator (auto trans) from around $149.00 for your vehicle.
  • mslot.ms
    mslot.ms - 1999 Mercedes Benz E320 - Engine - 2/8/2013
    Why is my ignitiongetting stuck in the on position,and why does my car cut of when im driving
    my ignition gets stuck when i try to start my car, and the engine just keeps turning over trying to start,when im driving my car cuts of,but the dashborard lights are still on,its getting power but the engine cuts off.my check engine light is on while im ...
     
    0 answer
 
AutoMD Verified Customer
AutoMD obtained proof this customer interacted with the shop.