Auto Answers » Engine » Kia » Page 7

Kia engine repair questions and answers

Post your Kia engine question or share what you know by answering questions

999 Questions
Sort by:
  • A1RodTire&Auto
    A1RodTire&Auto - 2004 Kia Sedona - Engine - 9/27/2013
    Vehicle runs hot while idling, water pump, thermostat & radiator all replaced. Cooling fan work Why still running hot?
    Only when idling does it run hot, while driving temp goes down
     
    • HouseCallAuto
      9/27/2013 HouseCallAuto
      Replace the Engine Coolant Temperature Sensor which may be giving a false reading to the gauge.
  • saudi.fast
    saudi.fast - 2007 Kia Magentis - Engine - 9/22/2013
    Show Fuse system in carnivel 2005
    air conditioner fuse system
     
    0 answer
  • lrufus51
    lrufus51 - 2003 Kia Optima - Engine - 9/21/2013
    How would i power wash the motor
    it have a lot of dust on it an i would like to clean it
     
    • Jimm
      9/21/2013 Jimm
      Keep the high pressure spray away from the alternator and avoid a direct flow into the air intake - and the engine wash should be OK.
      Jimm
      9/22/2013 lrufus51
      thank you jimm.
  • zippertf
    zippertf - 1997 Kia Sportage - Engine - 9/16/2013
    Have code P0 326 also dash light on, car goes into limp mode.
    P0326 states knock sensor CKT range/performance bank 1 or 1 sensor. Can anyone tell me what exactly what this pertains to?
     
    0 answer
  • rotarypower82
    rotarypower82 - 2002 Kia Spectra - Engine - 8/20/2013
    2002 KIA spectra gs lifter problems. Replaced cylinder head with a reman loaded head and now lifters won't pump up.
    I have started the engine and let it run for a minute or so at idle like three times and the lifters won't pump. I don't know if I am doing something wrong. I know with a new head and cams iI would need to break them in but this is a reman and no parts were ...
     
    0 answer
  • Lindsey
    Lindsey - 2008 Kia Rio5 - Engine - 8/12/2013
    2008 Kia Rio5 Takes Long Time to Start
    When I try to start my car it will turn over but will take a full 10 seconds to start. Sometimes I have to do this and turn it over for a second time before it will actually start. It does this all the time no matter the temperature or if I have been driving it ...
     
    • frankiedonnn
      8/12/2013 frankiedonnn
      Not having an engine light does not mean that a code is not set in the P.C.M. Free scans are available at your local auto. parts outlets like Advance Auto. Auto zone etc. if you can get the car there.A scan code will make the diagnosis a lot quicker.Was the air filter checked too and what is the condition of the battery ? A battery thats on the way out could cause no start condition. Check the expiry date of the battery and have a load -test done on it or replace it if the expiry date is gone.The battery is the life of the car.Try some fuel injector cleaner in the gas as the fuel injectors and the plugs could be dirty. Also look for loose wires in the ignition systm and the ground wires : shake the black wires that are connected to the body of the vehicle to be sure none are loose .Check the smaller things first .
      frankiedonnn
      8/24/2013 Lindsey
      Yeah I had it checked at advanced auto and everything was fine. Air filter is new. Now it starts just fine as long as the engine is cold. If I've been driving and stop somewhere on my way home it's very hard to start. Any ideas? Thanks for the help.
  • Ray
    Ray - 2010 Kia Optima - Engine - 8/9/2013
    Why won't my car start or the key turn on?
    I went to Walmart and I got out of the car and I tried to lock it with the remote pad. The car would not lock and the radio was still on and it wouldn't start or even turn over. It was like it was in limbo or something. It acts like it might be in the key place ...
     
    • frankiedonnn
      8/2/2013 frankiedonnn
      It seems to me that it is the security system if it has one.It may help if you can get it scanned. A local Auto Zone or Advance Auto. will do it for free . A fault code may be set in the p.c.m.
    • x431shop123
      8/9/2013 x431shop123
      check the starter and ignition.

      Launch X431
  • rjahrig
    rjahrig - 2008 Kia Rondo - Engine - 8/2/2013
    Why does my Rondo not accelerate quickly and loses power at high speeds and hills?
    It started doing this suddenly. It has just over 100,000 KMs. It starts fine and there is no black or blue smoke coming from the exhaust. The motor sounds fine and the transmission changes gears. It just doesn't have much oomph!
     
    • John's Auto Repair
      7/31/2013 John's Auto Repair
      You may want to try changing the fuel filter. And check the air filter too.
      John's Auto Repair
      7/31/2013 rjahrig
      Air filter just replaced. Fuel filter is in-line non-serviceable. Could it be fuel injectors or 02 Sensor?
    • Jimm
      8/1/2013 Jimm
      First step - have the stored fault codes or check engine light scanned - for free - at any local auto parts store; Advance Auto, Auto Zone, NAPA. Then, post a reply as 'add answer' with the specific code for more assistance. There may be a fault code stored in the OBD memory which may not be displayed as a check engine light.

      There is a fuel pump filter that is serviceable / replaceable - located in the fuel tank. This may be the issue.
      Try the Beck / Arnley pn 0433017 for around $12.00 - from the many on-line parts sources; www.autopartswarehouse.com, www.partsgeek.com, or www.rockauto.com - to list only a few sources.

      Possible Causes of Engine Hesitation or Stumble:

      Dirty fuel injectors (cleaning the injectors often fixes this)
      Dirty air filter (change filter)
      Dirty / clogged fuel filter (change filter)
      Bad MAP (manifold absolute pressure) sensor
      Bad TPS (throttle position) sensor
      Bad or dirty MAF (mass airflow) sensor
      Low fuel pressure (leaky fuel pressure regulator or weak fuel pump)
      Vacuum leaks (intake manifold, vacuum hoses, throttle body, EGR valve)
      Bad gasoline (fuel contaminated with water or too much alcohol)

      Sometimes, what feels like a hesitation is actually ignition misfire rather than lean misfire. The causes of ignition misfire may include:

      Dirty or worn spark plugs
      Faulty plug wires
      Weak ignition coil
      Wet plug wires
    • John's Auto Repair
      Fuel filter has to be serviceable. Check with part store like Autozone, etc.
  • tanya
    tanya - 2002 Kia Spectra - Engine - 7/21/2013
    Broken belt but car still running, what belt could it be?
    Found a broken belt inder the hood of the car but the car is still running
     
    • CVO
      7/21/2013 CVO
      There are two belts :
      1. Alternator / water pump.If this belt is broken, the alternator light in the dashboard is on.

      2. A/C compressor and power steering pump belt, then the car is hard to steer.
  • willy
    willy - 2005 Kia Sorento - Engine - 7/16/2013
    2005 sorento has a code po134 is this wats causing low idel and what is it
    car died but started back up but than had the code and a very low idle
     
    • CVO
      7/16/2013 CVO
      02 Sensor Circuit No Activity Detected (Bank I Sensor 1). Bank 1 is the side with the odd cylinders (1, 3, 5 ) and sensor 1 is before the catalytic converter.
      A code P0134 may mean that one or more of the following has happened:
      Bad O2 (oxygen) sensor
      Bad heater circuit in the O2 sensor
      Wiring or connector to the sensor frayed / broken
      Blown heater circuit fuse Holes in the exhaust system PCM failure

      The most common fix is to replace the oxygen sensor.
      But that doesn't rule out the possibility of:
      Rusted exhaust pipe Inspect wiring & connector(s) for problems
      Excessive amperage blowing heater fuse (still requires replacement of sensor but also replacement of blown fuse)
      Replace PCM (only as last resort after all other possibilities are covered.



  • rwbknoxville
    rwbknoxville - 2004 Kia Amanti - Engine - 7/13/2013
    Temperature gauge indicator runs above center line
    temperature gauge indicator runs above center cool line auto has 60,000 miles,,,never runs in red can this be an overheating mproblem
     
    • Jimm
      7/13/2013 Jimm
      Simply stated - the temperature guage 'red' zone is the overheating condition. As long as the temperature guage stays steady, does not climb - and the cooling system is maintained there is little concern for overheating. You may also monitor the coolant level over time - to determine if any leaks occur.

      The cooling system maintenance consists of these items (at a minimum);

      Periodic anti-freeze / coolant changes - at recommended intervals
      Using the correct and recommended anti-freeze / water mixture at 50/50 concentration
      Changing the radiator upper and lower hoses - recommended intervals such as every 24k miles
      Inspection and cleaning of the radiator fins - cleaning the dirt and bugs - such as with a water spray using a garden hose.
      Inspection of the serpentine and accessory drive belts - including regular replacement when the belt is worn

      As long as the recommended cooling system maintenence steps are followed - as outlined in the owners manual - you will minimize any problems.
      Jimm
      7/13/2013 rwbknoxville
      thank you for your reply...rwb very informative!
  • ronaldhagen67
    ronaldhagen67 - 2007 Kia Rondo - Engine - 7/11/2013
    Engine bearings bad need engine is my KIA Rondo still covered under the power train warranty?
    82,000 miles EST.
     
    • Jimm
      7/11/2013 Jimm
      For specific warranty coverage for your vehicle you would have to check with the local dealerships.
  • cody.sosin
    cody.sosin - 2001 Kia Sportage - Engine - 7/6/2013
    Why wont my car start and how can I fix it?
    there was an oil leak and now it wont start, please help.
     
    • Jimm
      7/6/2013 Jimm
      The engine needs three (3) components to start; fuel, air and ignition (spark). First step - check for spark at the spark plug. Remove one of the four spark plug leads and crank the engine to determine if the ignition is producing spark sufficient to ignite the plug. If the spark is strong and a blueish color - reinstall the plug wire onto the spark plug.
      If there is a weak or no spark - then back up one step and check the ignition coil output. Also, check the state of charge on the battery - a weak battery alone may cause weak spark and the engine not to run.

      Check the air intake system; air filter should be clean, the air intake boot should be clean inside and not damaged or cracked. The throttle body at the end of the air intake hose should be clean.
  • tondew1999
    tondew1999 - 2003 Kia Sorento - Engine - 7/4/2013
    Will 3.4 engine fit in this suv
     
    • Jimm
      7/4/2013 Jimm
      It depends on what vehicle; year, make and model the 3.4L engine is from. The Kia Sorento has been available with the 3.3L and 3.5L V6 engines.
  • tondew1999
    tondew1999 - 2003 Kia Sorento - Engine - 6/29/2013
    Will 3.4 engine fot in this suv
     
    0 answer
 
AutoMD Verified Customer
AutoMD obtained proof this customer interacted with the shop.