Auto Answers » Engine » Chrysler » Page 11

Chrysler engine repair questions and answers

Post your Chrysler engine question or share what you know by answering questions

2411 Questions
Sort by:
  • Cat
    Cat - 2006 Chrysler PT Cruiser - Engine - 10/15/2013
    How many issues can a "misfire in cylinder 2" be responsible for? I've changed plugs, wires, coil pack already
    The engine loses power when the a/c runs at idle. A/c stopped working all of a sudden and transmission fluid leaks
     
    • HouseCallAuto
      10/15/2013 HouseCallAuto
      Is the engine running like it has one dead cylinder? Do a compression test. Swap fuel injector with a different cylinder and if the fault code changes to different cyl then you know the injector is bad or just replace #2 injector. It may not solve it.
  • Lester L
    Lester L - 1997 Chrysler Sebring - Engine - 10/13/2013
    Oil leak coming from the timing belt cover was told cover has a crack on the bottom can that cause the leak
    Previous owner replaced water pump and timing belt bottom of cover is cracked looks like it was tightened to much
     
    • HouseCallAuto
      10/12/2013 HouseCallAuto
      Ok, I agree. What did you want to ask about this? Replace the timing cover.
      HouseCallAuto
      10/12/2013 Lester L
      When timing belt cover is mounted is it sealed where oil cannot leak out.And also when engine is running is oil suppose to circulate on timing belt and other moving parts.Just want to make sure my mechanic is being honest with me.Thanks for any info.
    • HouseCallAuto
      10/13/2013 HouseCallAuto
      Yes the area around the moving timing belt has to be free from oil contamination and the timing cover would seal out oil leakage. Ask the mechanic to see the crack in the timing cover.
  • phillipudaniels
    phillipudaniels - 2006 Chrysler Sebring - Engine - 10/7/2013
    Why is my car having electrical probems?
    Theses electrical problems started happening with my 2006 Chrysler Sebring, 4 door, one by one, over a period of two years: 1st. My automatic lock and lock control does not work on the driver side. 2nd. Some dahsboard lights (air, radio) would delay to come on. ...
     
    0 answer
  • willettc1989
    willettc1989 - 2005 Chrysler PT Cruiser - Engine - 10/6/2013
    Is something wrong with my car's engine?
    My car has 113,000 miles. Recently it has been having problems overheating. I was intending on checking the water pump, but before I got that chance, my oil light came on. Within minutes I lost power. I've put oil and water in their respective tanks and the car ...
     
    • Jimm
      10/6/2013 Jimm
      The white smoke is not a good sign; more than likely - the cylinder head gasket has a leak due to the overheating.
      As the first step; perform a cooling system / radiator pressure test when the engine is cold - to locate the leak.
      Obtain a loaner tool / free radiator pressure tester from the local auto parts stores such as Autozone, O'Reilly, NAPA, Advance Auto, or PepBoys. Follow their instructions and pump it to an adequate air pressure 12 -15 psi or the pressure rating listed on the radiator or reservoir cap. Observe the leaks and perform the repair.
      Note: do not over pressurize beyond the pressure allowed by the radiator cap, then test the radiator cap as well.

  • murali_2in
    murali_2in - 2004 Chrysler Sebring - Engine - 10/5/2013
    Why did my car take time to crank up slowly with vibration while starting?
    I was trying to restart the engine after a 15 min stop after running it for an hour. It did not respond initially, and then when I kept pressing on the gas pedal, it cranked up slowly with vibration. Once it got started, it was running normal
     
    • HouseCallAuto
      10/5/2013 HouseCallAuto
      Hard to say. The details don't clinch it. Need more. Check fault codes and see what might be there.
  • murali_2in
    murali_2in - 2004 Chrysler Sebring - Engine - 10/5/2013
    Why did my car take time to crank up slowly with vibration while starting?
    I was trying to restart the engine after a 15 min stop after running it for an hour. It did not respond initially, and then when I kept pressing on the gas pedal, it cranked up slowly with vibration. Once it got started, it was running normal
     
    0 answer
  • murali_2in
    murali_2in - 2004 Chrysler Sebring - Engine - 10/5/2013
    Why did my car take time to crank up slowly with vibration while starting?
    I was trying to restart the engine after a 15 min stop after running it for an hour. It did not respond initially, and then when I kept pressing on the gas pedal, it cranked up slowly with vibration. Once it got started, it was running normal
     
    0 answer
  • scarlha
    scarlha - 1993 Chrysler Concorde - Engine - 10/4/2013
    Plenum gasket replacement
    Inoperative PCV valve (am told) has caused failure of the valve cover gaskets and the "plenum gasket". In order to stop oil leak(currently 1 qt./1000 miles) all 3 items must be replaced together (valve replaced alone is no help). True or false? And what search term ...
     
    • John's Auto Repair
      10/4/2013 John's Auto Repair
      You can use AutoMD to find the cost. The intake passage to the PCV valve must be clogged.
  • willettc1989
    willettc1989 - 2005 Chrysler PT Cruiser - Engine - 10/1/2013
    Is something wrong with my car's engine?
    My car has 113,000 miles. Recently it has been having problems overheating. I was intending on checking the water pump, but before I got that chance, my oil light came on. Within minutes I lost power. I've put oil and water in their respective tanks and the car ...
     
    • HouseCallAuto
      10/2/2013 HouseCallAuto
      Its hard to say what has happened here. You have a asked a question that will not be able to be answered without a qualified mechanic looking at the car. Mybe the timing belt broke and that is the "whine" you now hear when trying to start it. I hope that is not what happened because it causes other damage at the same time.
  • joe_a_nicholls
    joe_a_nicholls - 2006 Chrysler Sebring - Engine - 10/2/2013
    Check engine light comes on after about 400km [about a week of driving] after being turned off
    mileage- just over 50000km,no noticable symptoms, engine light comes on when engine is warm, after I turn the light off it stays off for about a week of driving. The code is P2098 post catalyst fuel trim too lean bank 2.
     
    • HouseCallAuto
      10/2/2013 HouseCallAuto
      Replace the downstream oxygen sensor. probability here is greater than 75%.
  • kayla.engeman
    kayla.engeman - 2000 Chrysler Town & Country - Engine - 10/1/2013
    Alarm systemWhat I believe to be the alarm system locking us wont let the van start. It will start for 10 secs three tim
    What I believe to be the alarm system locking us wont let the van start. It will start for 10 secs three times and then nothing will happen. Replaced the pcm and instrument cluster checked to see if its the key but the key doesn't have a chip.
     
    0 answer
  • fred_samples
    fred_samples - 2003 Chrysler Voyager - Engine - 9/29/2013
    Why is my gas mileage way down?
    The car has 12800 miles but runs good.
     
    0 answer
  • drodgers1764
    drodgers1764 - 1987 Chrysler LeBaron - Engine - 9/28/2013
    Wont start after running out of gas
    it stopped running i replaced the idel control valve and it ran untill the wife ran out of gas now it wont start there is gas getting to the throttle body
     
  • jasonhuffman44
    jasonhuffman44 - 2001 Chrysler Voyager - Engine - 9/27/2013
    When i go to start vehicle it will give me one click and wont start.if i keep doing this it will eventually start.
    110,000 miles.i can turn it off then try to restart right away and it does the same thing.i replaced the starter relay,didnt help.i can have no problems for days in a row then it starts to act up.i thought maybe the starter but all the other starters ive replaced ...
     
    • CVO
      9/27/2013 CVO
      Resistance developed in the old battery cables will slow down the electrons to flow through the starter circuitry.
      Replaced the battery cables ( positive and negative).
      Note: don't use the terminal battery clamps for a replacement, they intend to go bad or loose their strength.

  • jasonhuffman44
    jasonhuffman44 - 2001 Chrysler Voyager - Engine - 9/27/2013
    Van wont start.it will just give me a click,if i continue to try it will start.is it my starter or the battery?
    van has 110,000 miles on it.i can go for a few days with this not happening then it will start to act up.
     
    • HouseCallAuto
      9/27/2013 HouseCallAuto
      If the battery terminals are both clean and tight then your starter is junk.
 
AutoMD Verified Customer
AutoMD obtained proof this customer interacted with the shop.