Auto Answers » Transmissions & Drivetrains » Chevrolet » Page 7

Chevrolet transmissions & drivetrains repair questions and answers

Post your Chevrolet transmissions & drivetrains question or share what you know by answering questions

Browse Chevrolet Categories

2509 Questions
Sort by:
  • AutoMD Member
    AutoMD Member - 1997 Chevrolet C1500 - Transmissions & Drivetrains - 2/28/2014
    Why is there sporadic acceleration jumpiness and speedometer not working right after a new speed sensor was put in truck
    We just had a new Speed Sensor put in our 1997 Chevy Silverado because it was not shifting out of low gear. Now when I accelerate there sporadic jumpiness, though no change in pressure on the accelerator. Also the speedometer isn't working right now and the gauge ...
     
    • Jimm
      2/28/2014 Jimm
      On GMC models made before 1996, disconnect the battery to clear all the trouble codes stored in the computer. On vehicles made after 1996, clear the codes using an automotive scan tool. Test-drive the truck to verify the repair.

      The scan tool can be found at any local auto parts store - they will usually read and reset any codes for free.

  • horace
    horace - 2002 Chevrolet Trailblazer - Transmissions & Drivetrains - 2/28/2014
    How do I know if my auto Trans has to be replaced?
    When I put my vehicle in drive I have to press the accelerator really hard to get vehicle to move or put the Trans in low gear 2 When I'm driving, the transmission is not switching gears
     
    • Jimm
      2/28/2014 Jimm
      Most likey due to a pump failure, or loss of fluid. Remove transmission and rebuild, or refill pan and find the leak.
      If out of fluid, avoid running the engine until the transmission is refilled to avoid pump damage. To check for pump failure, check fluid level with the engine off, then start the engine and recheck fluid level. If level does not go down when engine is running, the pump is broken.
      Jimm
      2/28/2014 horace
      It's not leaking fluid and the flu dis not dark
      Jimm
      3/1/2014 horace
      I did the fluid check and the fluid level changes with the engine on the level drops
  • Apache
    Apache - 1998 Chevrolet Tahoe - Transmissions & Drivetrains - 2/27/2014
    I was driving at 57mph on cruse control (98 Tahoe 4wd 4L60e tranny, 5.7 engine) felt a light thud. rpm suddenly shot up
    in idle tranny fluid level is very high like pump not working.
     
    • HouseCallAuto
      2/22/2014 HouseCallAuto
      I agree, the pump went out and the typical detail that I always see is a high fluid level right after that as all the fluid settles in the bottom of the unit. Its no different than checking the unit with the engine off. You need a transmission.
      HouseCallAuto
      2/23/2014 Apache
      can I just replace the pump. it was rebuilt about 2 years ago. the fluid is very good almost no debris on the magnet. I have already removed the tranny.
      HouseCallAuto
      2/23/2014 HouseCallAuto
      I don't see why not. The hardest part is already done. Good work.
      HouseCallAuto
      2/25/2014 Apache
      OK changed the pump it drives but...in drive no third gear, high rpm, rpm gauge fluctuates no speedometer. are the wires are wrong?
    • HouseCallAuto
      2/25/2014 HouseCallAuto
      Vehicle speed sensor not making signal. Is there a fault code stored P0500 or P0501?
      HouseCallAuto
      2/27/2014 Apache
      Only fault code is P0102 (MAF) which I know about. I reset and retested. Installed new 1-2 and 3-4 shift solenoids. Now the ABS light is on. in drive no 3rd gear, have manually shifted from 1-2-3, the gears are there, no overdrive. Was working fine before the pump went. Can the harness be connected wrong? Don't get it.
    • HouseCallAuto
      2/27/2014 HouseCallAuto
      There is a problem with the vehicle speed sensor which on a 4wd is located on the transfer case. There are two, a front speed sensor and a rear speed sensor. Check your connectors and wiring that goes to their connections at the transfer case.
  • Travis
    Travis - 2008 Chevrolet Aveo - Transmissions & Drivetrains - 2/27/2014
    Getting trouble code P 2176. Wondering what it means and what all steps I need to do to fix it
    Iling very rough will not go over 20 miles an hour
     
    • Jimm
      2/27/2014 Jimm
      P2176 = Minimum Throttle Position Not Learned
      The P2176 code is set whe the difference between the predicted and the actual throttle position is more than a calibrated amount for more than 1.5 seconds.

      Possible causes:

      - Faulty Throttle Actuator Control (TAC) module
      - Throttle Actuator Control (TAC) module harness is open or shorted
      - Throttle Actuator Control (TAC) module circuit poor electrical connection
      - Throttle plate sticking due to carbon build-up
      - Engine Control Module

      Jimm
      2/27/2014 Travis
      Thank+you+for+the+information+I%27ll+see+what+I+can+find+out
  • AutoMD Member
    AutoMD Member - 2004 Chevrolet Suburban 1500 - Transmissions & Drivetrains - 2/27/2014
    Transmission indication does not illuminate
    about 133000 miles on vehicle and it occures all the time
     
    • Jimm
      2/27/2014 Jimm
      Replace the indicator bulb and check the socket and wiring / connections. The issue may also be related to the ignition switch - check this webste for further information; www.howstuffinmycarworks.com/GM_truck_bad_ign.html
  • impossible install
    impossible install - 1994 Chevrolet Camaro - Transmissions & Drivetrains - 2/24/2014
    Installing motor and transmission
    im installing a LT1 motor into a GMC 2500 sierra and i have a 700r4 trany i have the ecm (brain and harness)for the motor but plugs dont match trany what do i need to do to make this work aside from getting a 4L60E trany
     
    • HouseCallAuto
      2/24/2014 HouseCallAuto
      There is no workaround for this situation that I ever heard of. There is no "adaptor" that will make this work.
      HouseCallAuto
      2/24/2014 impossible install
      thank you i was afraid of that
  • AutoMD Member
    AutoMD Member - 2004 Chevrolet Impala - Transmissions & Drivetrains - 2/23/2014
    In any gear drive through first when starting off the rpm's raise to 3000 before the car moves.like it being held back
    Once moving it shifts gears fine but has no over drive when you hit the gas.The performance isn't there. If you step on the gas in reverse she will snap your head foward. I also had smoke in the drivers compartment before this happened and my heater and air will not ...
     
    • HouseCallAuto
      2/23/2014 HouseCallAuto
      There has to be fault codes stored. Do you want to try to diagnose this yourself or you are looking to get info on what to expect a shop might tell you?
  • Apache
    Apache - 1998 Chevrolet Tahoe - Transmissions & Drivetrains - 2/22/2014
    I was driving at 57mph on cruse control (98 Tahoe 4wd 4L60e tranny, 5.7 engine) felt a light thud. rpm suddenly shot up
    in idle tranny fluid level is very high like pump not working.
     
    • alex
      2/22/2014 alex
      the input shaft is pretty tough . but to check the pump you could unhook a trans cooler lines start it and see if its pumping oil no matter what let go the trans will have to come out. you could pull it yourself but most trans shops wont warrenty it unless they put it in. also your trans cooler. chunks of metal will get pushed into it and there's no way to clean it all out and it will wreck a new tranny.
  • Apache
    Apache - 1998 Chevrolet Tahoe - Transmissions & Drivetrains - 2/22/2014
    I was driving at 57mph on cruse control (98 Tahoe 4wd 4L60e tranny, 5.7 engine) felt a light thud. rpm suddenly shot up
    in idle tranny fluid level is very high like pump not working.
     
    0 answer
  • AutoMD Member
    AutoMD Member - 2000 Chevrolet Silverado 1500 - Transmissions & Drivetrains - 2/22/2014
    What would cause severe shaking of front end while turning in 4WD?
    Seems like one wheel is trying to "catch up" with the other one. Much worse in low range but probably due to higher engine speed. Have replaced both CV axles, grease in the front differential. Does this only in 4 WD, and when not turning everything works smoothly.
     
    0 answer
  • AutoMD Member
    AutoMD Member - 2004 Chevrolet Malibu - Transmissions & Drivetrains - 2/21/2014
    Why did my car did not started up and nothing worked
    I parked my car this morning and could not lock the car with keyless remote, when I try to start the car up nothing worked, This was the first time this happening. I removed the battery cover and checked the battery (fine) turned the ignition key and car started ...
     
    • HouseCallAuto
      2/21/2014 HouseCallAuto
      Not enough to go on to advise. There might be a fault code stored in the PCM or BCM but reading the BCM code requires a professional scan tool.
  • AutoMD Member
    AutoMD Member - 1991 Chevrolet Blazer - Transmissions & Drivetrains - 2/20/2014
    Looking for a reputable automatic transmission shop in the Portland Or metro area
    I have a 1991 Chevy full size Blazer 4x4 with TH700R4 transmission. was driving suddenly it acted like it slipped into neutral and that was it no more gears There was a slight vibration in park when cold at start up. fluid levels full and fairly recent change. now ...
     
    • Jimm
      2/20/2014 Jimm
      Use the 'Find-A-Shop', Estimate Cost and instant quotes features on the AutoMD website to locate a transmission repair shop in your area. Also, try word-of-mouth - ask around for recommended and trusted repair shops - often this is the best advertsing anyway.
    • HouseCallAuto
      2/20/2014 HouseCallAuto
      *Consider* buying your own rebuilt transmission and then you can have a choice of many more shops that can just "install" your unit. You will not be forced to deal only with tranny shops. Sometimes it works out better.
  • AutoMD Member
    AutoMD Member - 2005 Chevrolet Venture - Transmissions & Drivetrains - 2/20/2014
    Why won't my car start? Problems with P/N safety switch...
    I am having trouble with my 2005 Chevy venture. It is sometimes not starting. We have replaced the park neutral safety switch (thought to be the cause). when we turn the key if the P (park) or N (neutral) lights on the gear shift do not light up it will not start. ...
     
    0 answer
  • daniel
    daniel - 2004 Chevrolet Impala - Transmissions & Drivetrains - 2/19/2014
    I received code P1811 on my 2004 Impala. Every now and then car jerks but now all I hear is a whining sound please help!
    Changed oil pressure sensor (different code issue) and trans code disappeared but still having shifting issues. FWD, ATM.
     
    • Jimm
      2/19/2014 Jimm
      Code P1811 is hands down the most common trouble code and commonly asked about problem. This code can set for numerous reasons and often by a failing pressure control, but on higher mileage transmissions this is often not the case or at least is not the only cause to the problem. With that said it is important to understand that replacing the pressure control solenoid is not a guaranteed fix.

      This code will set when the pcm/tcm detects excessively long shift times. For every shift the pcm/tcm watches how long the shift takes to complete in milliseconds. If the shift times are over roughly the .06 second timeframe and the pcm/tcm tries to compensate for this by raising line pressure and still does not see acceptable shift times after a few shift cycle it will trigger code P1811. When this happens it puts the transmission in a max line pressure condition to help protect the transmission against excessive slippage and burnt clutches. While this condition is present you will feel harsh shifts, some vehicles more agressive than others, and you will also hear a whine noise similar to what a power steering pump that is low on fluid will sound like. You can shut the engine off for a brief moment and restart the vehicle and it will feel normal again until a few shift cycles of excessive shift times and the cycle will repeat itself. This typically only happens after you have driven for a short while and the transmission and its fluid warms up.

      Some common causes to this problem are-

      -Poor working PCS (Pressure Control Solenoid), also called EPC or Force Motor
      -Excessive clutch clearances
      -Poor functioning accumulator system
      -Worn internal seals and sealing rings
      -Excessive valve body wear
      -Dirty MAF sensor resulting in lower commanded line pressure

      Due to the list of potential problems it is difficult to suggest just one or two items to cure code P1811 as everything above and many other parts and variables all play a role in the effect. Unfortunately because of the orientation of this transmission and how it sits in a vehicle it requires quite a bit of labor to access the pressure control solenoid as well as the valve body.
      One thing popular to try before diving into an expensive and labor enduring repair is to install a shift improver kit such as the many shift kits that are available. This kit includes a new set of accumulator springs and spacers to limit accumulator piston travel which greatly speeds up the time it takes to apply a clutch, which hand in hand will shorten the shift time.

      Going to the expense of installing a shift kit as comparable to having the transmission rebuilt - so choice is yours.
      Jimm
      2/19/2014 daniel
      My car has 122,300 miles on it I was told it could be one of 3 things: needs a fluid change, bad torque converter, or a malfunctioning PCS
      Jimm
      2/19/2014 daniel
      But it is not a constant code it only shows itself when another problem code is present
    • HouseCallAuto
      2/19/2014 HouseCallAuto
      If replacing the PCS does not solve this then the tranny needs to be replaced.
  • AutoMD Member
    AutoMD Member - 2010 Chevrolet Impala - Transmissions & Drivetrains - 2/17/2014
    My car will not move into gear, it just sat at the light and would not go into gear
    car has 71,000 km on it and is still under warranty for power train. I had the car towed on Saturday to dealer where I bought it. What do you think the problem could be it would not do anything in drive, reverse 1st 2nd or 3rd it is an automatic. They have not ...
     
    • HouseCallAuto
      2/17/2014 HouseCallAuto
      Sure does sound like an internal transmission failure to me.