Auto Answers » Engine » Buick

Buick engine repair questions and answers

Post your Buick engine question or share what you know by answering questions

1867 Questions
Sort by:
  • AutoMD Member
    AutoMD Member - 2005 Buick Century - Engine - 7/10/2014
    Original radio and wires removed. Now car won't start.
    Battery, starter and alternator tested working fine
     
    0 answer
  • AutoMD Member
    AutoMD Member - 2005 Buick Century - Engine - 7/10/2014
    Original radio & wires were removed. Now car won't start.
    Battery,starter and alternator all tested and working fine.
     
    0 answer
  • AutoMD Member
    AutoMD Member - 2005 Buick Century - Engine - 7/10/2014
    Original radio & wires were removed. Now car won't start.
    Battery,starter and alternator all tested and working fine.
     
    0 answer
  • AutoMD Member
    AutoMD Member - 2005 Buick Century - Engine - 7/10/2014
    Original radio & wires were removed. Now car won't start.
    Battery,starter and alternator all tested and working fine.
     
    0 answer
  • AutoMD Member
    AutoMD Member - 1986 Buick LeSabre - Engine - 7/5/2014
    My buicks battery kepts going dead it takes about 1 day for it to die. I have put a new alternater on . A new
    belt. a new head light switch. Also my tail lights have gone out.and licenses plate lights out . I still have brake lights. Whats next help
     
    • jdl
      7/5/2014 jdl
      As far as your charging system, use a digital multimeter and do some testing. First, you need to make sure the battery has a full charge, all battery connections in good shape. With everything off, the meter leads across battery posts, the generic spec for a full charge is around 12.6 volts. Then start the vehicle, take second reading across battery posts, engine running, the second reading should be higher than the first if charging system is working.

      Also, check for battery drain with everything off, amp draw. Usually shouldn't be more than 50 ma, that is .050 amps, not even a tenth of an amp.

      We can check tail lamps later. Have to check voltage--ground--bulbs and maybe wiring circuit for lamps.
  • AutoMD Member
    AutoMD Member - 1989 Buick Skyhawk - Engine - 6/28/2014
    Speedometer is erratic
    it is fairly smooth til it gets up to 35 mph, then it flops all over the place. also idles a little rough misses randomly
     
    0 answer
  • James
    James - 1996 Buick Regal - Engine - 6/27/2014
    My car won't start when it gets hot.
    The car gets hot easily and it will drive fine but when I park and turn the engine off to go into a store, when I come back out and restart it , it will start run for a few seconds then act like it's not getting fuel by spitting and sputtering and then it will die. ...
     
    0 answer
  • AutoMD Member
    AutoMD Member - 2003 Buick Regal - Engine - 6/25/2014
    Engine kills when first started
    engine killed one time while driving
     
    • CVO
      6/25/2014 CVO
      The check engine light doesn't have to be ON to store a fault code.

      Check the vehicle for fault codes to see if there are any sensors were involved to the malfunction of the engine.

      1.Local auto parts stores such as Autozone ( not in California) or Advance Auto parts will scan and retrieve any diagnostic trouble codes ( dtc ) stored in the powertrain control module for free of charge..

      2. Amazon.com has the code reader for less than $ 18.00 dollars + shipping
      Autel MaxiScan MS300 CAN Diagnostic Scan Tool for OBDII Vehicles

      3.Re-post the dtc's in here " answer question " for further assistance.

      Note: we need the dtc's to identify the sensor, there are a dozen different sensors to operate the car.

      Visit this site and see all the different sensors.

      www.freeautomechanic.com
  • AutoMD Member
    AutoMD Member - 2005 Buick LeSabre - Engine - 6/20/2014
    Why is the oil light coming on
    oil light comes on and instrument cluster reads low oil pressure
     
    0 answer
  • AutoMD Member
    AutoMD Member - 1996 Buick Park Avenue - Engine - 6/19/2014
    Loosing coolant, looks like coolant on motor above waterpump.
    THERE LOOKS LIKE AN ELBOW PIPE CONNECTIONG INTAKE MANIFOLD AND MOTOR BLOCK, IS THER O RING SEALS ON ELBOW PIPE. AND DOES IT JUST PULLOUT OF MOUNTING.
     
    0 answer
  • AutoMD Member
    AutoMD Member - 2002 Buick LeSabre - Engine - 6/15/2014
    Why won't my Buick start? It was working FINE before I disconnected the battery!
    I don't know much about cars but for some ODD reason I decided to disconnect the negative battery. Big mistake now my car won't start? I can turn the key to ON and some instruments light up, but when i try to start the car , NOTHING. If i listen close there is a ...
     
    • GT500Knights
      6/15/2014 GT500Knights
      Have your battery tested at any local shop for free. If it passes, your problem may be due to loose/corroded connections at the battery terminals and/or starter motor and relay. Any green-bluish growth around connections is a buildup of corrosion and needs cleaning.

      If the starter motor does not have enough power supply from the battery, it will either make a machine-gun like clicking noise or not do anything at all if the connections are too loose or if the battery charge level is too low.
  • AutoMD Member
    AutoMD Member - 2002 Buick LeSabre - Engine - 6/14/2014
    Why won't my Buick start? It was working FINE before I disconnected the battery!
    I don't know much about cars but for some ODD reason I decided to disconnect the negative battery. Big mistake now my car won't start? I can turn the key to ON and some instruments light up, but when i try to start the car , NOTHING. If i listen close there is a ...
     
    0 answer
  • AutoMD Member
    AutoMD Member - 2002 Buick LeSabre - Engine - 6/14/2014
    Number five cylinder is miss firing which was diagnosed as an intake leak. They put a new intake gasket on.
    Still Miss fires at an idle. runs fine when you accelerate. new plugs and wires. They say its a bad vavle or cracked head now.
     
    0 answer
  • AutoMD Member
    AutoMD Member - 2006 Buick LaCrosse - Engine - 6/11/2014
    Need help putting fuse wires back together.
    Fuse box melted last week, so I pulled it out, replaced the necessary wires, but I didn't recount which wire went where. All I have is this picture I thought to take after I took out 7 wires. http://oi59.tinypic.com/2dj9ze1.jpg
     
    0 answer
  • AutoMD Member
    AutoMD Member - 2006 Buick LaCrosse - Engine - 6/11/2014
    Need help putting fuse wires back together.
    Fuse box melted last week, so I pulled it out, replaced the necessary wires, but I didn't recount which wire went where. All I have is this picture I thought to take after I took out 7 wires. http://oi59.tinypic.com/2dj9ze1.jpg
     
    0 answer
 
AutoMD Verified Customer
AutoMD obtained proof this customer interacted with the shop.