Auto Answers » View Question
sdw25
sdw25 2/17/2014
2004 Chrysler Pacifica Base 6Cyl3.5L - Engine
I replaced fuel pump but now it will not crank I am not getting fuel to engine what do I do now pump is coming on
The whole thing started with bad egr sensor fixed it then had no power so changed fuel pump be caused the vehicle would bog down and stall while pressing the throttle
3 Answers
  • jdl
    jdl 2/17/2014
    Are you saying the starter won't crank? If it cranks good but won't start, have a helper crank it while you check for spark at the spark plugs and fuel pressure.

    If no fuel pressure, check voltage and ground at the fuel pump wiring, engine cranking. When you first turn on the key, engine off, you should hear the fuel pump run for a few seconds.

    Your electrical systems are all good? Battery has a full charge? The vehicle didn't go into theft lock?
    Reply
    0
    jdl
    sdw25 2/21/2014
    Ok I will check it iut
  • HouseCallAuto
    HouseCallAuto 2/17/2014
    I need you to tell the full story from the beginning or aty least from the time everything was working ok and then the first thing you did and the time inbetween. All details. I get a lot out of hearing the story, it helps me diagnose what went wrong. No short assuming sentences please. Plug in a code reader and give me fault codes too.
    Reply
    0
    HouseCallAuto
    sdw25 2/21/2014
    I just replaced the fuel pump now the car will start but idle dies immediately. It will only start if you hold the throttle all the way down
    HouseCallAuto
    sdw25 2/24/2014
    car had poor accelertion then the egr valve went bad according to the codes i replaced it with no improvement. i replaced the throttle position sensor and cleaned idle control valve the vehicle was still running but was stalling and top speed 10 mph.while on a test drive to see if it wamy s working properly it ran out of the gas, i got it to crank back up after putting fuel in i was told to replace the fuel pump because it was struggling when put under a load .
    HouseCallAuto
    sdw25 2/24/2014
    also no codes showing and i have now changed the crank sensor but still no improvement
  • AutoMD Member
    AutoMD Member 2/20/2014
    check the wiring of the fuel pump relay. change it if need be.
    Reply
    0
close

Preview Answer

 
AutoMD Verified Customer
AutoMD obtained proof this customer interacted with the shop.