Auto Answers » View Question
tonys13831
tonys13831 10/25/2010
1992 Dodge B350 Base 8Cyl5.9L - Engine
not getting power to ignition coil or fuel pump what would cause both losses of power together?
also analizer says not communicating
3 Answers
  • Bobby
    Bobby 10/25/2010
    could be a bad on board computer if the power for those circuits are through the computer, or possible there grounds are.

    You could also be looking at the possibility these are unrelated and seperate pwroblems and it is just coincidence.

    Start testing checking for power to the main fuse panel, check relays check for any burnt wires or melted. Does the car crank?
    Reply
    0
    Bobby
    tonys13831 10/25/2010
    van cranks just fine, just no spark. went to pull away from stop sign, gave it gas it moved a few feet and died. neighbor who is a mechanic put portable analizer on it and it says not communicating. he says he is not good on electrical systems so i'm kinda stuck
  • CVO
    CVO 10/26/2010
    My 92 dodge Caravan V6 3.0 had that same problem about 2 months ago. I connected my scanner and a link error communicating displayed.The car cranks, but the dashboard lights went up for a few seconds and all's lights disappeared ( no sparks, no smelling gas from the exhaust pipes ). Master HouseCallAuto asked me to check the voltages went in to the computer harness ( which all were present ) and cycled the ignition switch to see if the Automatic ShutDown (ASD) relay was working ( apparently it was not). I replaced the powertrain control module for $180.00 dollars (PCM) and it runs like champ now ( no more engine stalled at the traffic or stop signs, the speedometer behavior was long gone).A Million Thanks to Master HouseCallAuto. Hope this helps and be safe.
    Reply
    0
    CVO
    CVO 10/26/2010
    Master Bobby was absolutely right about a bad board computer. Talk to the autoparts stores managers ( kindly ), if they will accept to let you loaned their PCM (it won't hurt to ask ).
  • simoneau2007
    simoneau2007 3/7/2011
    i have a 94 jeep grand cherokee and i don't get pwer to the ignition coil and the feul pump. I get down to it its not the fuel pump when i hear the relay clicking i turn the key and start the jeep and its runs great but when u shut it off and let it sit for 3 mins you have to do the same thing wait until you hear the relay go off again i need help to find out what is wrong. what i read on online about pcm i don't thing its that either but that be the last thing im going for that cost $$$$
    Reply
    0
    simoneau2007
    Bobby 3/7/2011
    If the relay is sticking have you tried a new relay yet simoneau? You might want to start there you are describing that eventually the relay kicks, so it very well could be the relay its worth trying.
    simoneau2007
    simoneau2007 3/8/2011
    i check the relay last night and it giving me power to all but one when its off why is that
    simoneau2007
    simoneau2007 3/8/2011
    i was just outside and for broke wires and stuff like that when i was under the dishbord i find a wire that hook up to the ignition and other one hook up to the ground but both of them don't hook up to anything but they both was tape together with the ends open touching each other will that do anything no starting the power to start the jeep. I have to change the bartery because i lift something on last night oppes lol but plz get back to me on that thank you
close

Preview Answer

 
AutoMD Verified Customer
AutoMD obtained proof this customer interacted with the shop.