Auto Answers » View Question
david
david 5/23/2010
1987 Chevrolet R10 Silverado 8Cyl5.7L - Engine
fuel system 1987 chevy pickup 350 engine
This truck ran fine until two days ago, thought fuel pump was out replaced it with new on new one has 12 - 17 psi is this enough psi? Truck still would not start was told it was MAP sensor replaced it truck still want start? Truck has new starter and new battery but battery is only 650 cranking amps? The injectors in throttle body does not spray fuel when trying to start, but if I prime it with a little gas it cranks and runs fine but after a few mintues it will idle ruff and die unless i unplug new MAP sensor then it will run ok untill I shut the engine off then it will not start back unless I prime the thottle body again, injectors just want spray fuel while the motor is trying to start but does after it is running, I wished someone could help me out today really need to go to work tomorrow so I need the truck running. ASAP. Really at wits end here.
5 Answers
  • Allen
    Allen 5/23/2010
    With a fuel injected engine you need at least 50 lb.of fuel pressure.You can close off the return fuel line that goes to the tank with a pair of channel locks ,if it runs then ,it is your fuel pressure regulator bad.
    Reply
    0
  • HouseCallAuto
    HouseCallAuto 5/23/2010
    This is incorrect information. This Chevy truck is a low pressure system and the correct pressure should be 9 - 13 psi. I am researching the cause of your dilemma. Your fuel pressure reading 17 is high but is not the cause.
    Reply
    0
  • HouseCallAuto
    HouseCallAuto 5/23/2010
    Make sure the map sensor and TPS connectors are not turned around. The map sensor, TPS and engine coolant temperature values have to be looked at on a scanner to proceed in a productive direction.
    Reply
    0
  • david
    david 5/24/2010
    Have change map sensor , fuel pump, fuel filter, engine coolant sensor, TPS is almost new, new plugs and plug wires, truck ran great until Monday when it just loped a cupple of times and quit will runn now but you have to prime throttle body, fuel was spraying good when truck was running but now one injector don't spray as good but truck will run if primed first smells like it is running a little rich. but will not run if map sensor is plugged up ?????? was running last week fine with everything plugged up, This is beginning to cost to much and not getting it working , parts store said change this and that well at 12.00 to 80.00 per item really costing not to get it right can anyone help me.??????????????????????????????????????
    Reply
    0
  • HouseCallAuto
    HouseCallAuto 5/24/2010
    Yes, I can help you but there is information that I need to proceed so that I don't throw more parts at it. If the vehicle were in my hands I would have a scanner hooked up to the diagnostic connector and would be able to read the values of the coolant, TPS and MAP sensors. We cannot do that because you do not have access to this scanner which is the proper way so here we are.....with maybe's and guessing but that is all we have without this information. Make sure that the wires for the fuel injectors are not shorting out under the metal spacer ring on top of the throttle body. Make sure that the map and tps sensor connectors are not turned around.
    Reply
    0
    HouseCallAuto
    david 5/25/2010
    engine for the map sensor is green and the tps is black, I will check the wires to the fuel injectors are ok in the morning, Really don't understand why when we replacesd the map sensor the motor will not run now with it hooked up. I really are putting money in this that i might not should have but we have really change things that cost like fuel pump , map, I know this has to be something simple because the truck was running fine, I towed it with a two wheel car dolly from St Louis to my home
    HouseCallAuto
    david 5/25/2010
    I also would like for someone to tell me about my started it make a metal to metal sound when turning over the old started didn't do that, when I checked with parts stor they told me there was five different starters for my truck how do I know which one will work with out it making a metal to metal sound, we have tried shimming it but nothen helps, I think it is the wrong started.
close

Preview Answer